Back to overview
Degraded

Performance Issues

Feb 7, 2023 at 1:00pm UTC
Affected services
Portal
Integration (MEBroker)

Resolved
Feb 7, 2023 at 8:30pm UTC

The problem was solved

Created
Feb 7, 2023 at 1:00pm UTC

Our team is working to solve the issue as fast as possible